10748 Rate this article:
5.0

ENVI 5.3 Release Notes

See the following sections:

Supported Platforms

Platform  Hardware  Supported Versions 
Windows Intel/AMD 64-bit 7, 8, 10
Macintosh Intel 64-bit OS X 10.9, 10.10
Linux Intel/AMD 64-bit Kernel 2.6.32, glibc 2.12

An X-Windows manager is required for Macintosh. The software products were tested using XQuartz 2.7.4.

ENVI Classic is also supported on Solaris 10 SPARC 64-bit systems.

For optimal performance, your video card should have a minimum of 1 GB of RAM and should support OpenGL 2.0 or later. Also be sure to install the latest drivers for your video card.

An HTML5-compatible browser is required to view the ENVI Help.

New Features

ENVI 5.3 includes the new and enhanced features listed below. See the following sections:

Sensors and Data Formats

ENVI reads and displays imagery from the following sensors and data formats:

  • Deimos-2
  • DubaiSat-2
  • Pleiades-HR and SPOT mosaic tiles
  • GeoPackage vectors
  • Google-formatted SkySat-2
  • Sentinel-2

Image Processing

Point Clouds

Use the Generate Point Clouds by Dense Image Matching tool to create point clouds in LAS format from two or more satellite images taken from different view points. The following sensors are supported:

  • DPPDB with a generic RPC sensor model
  • GeoEye-1 in DigitalGlobe format (.til) and PVL format
  • IKONOS
  • Pleiades-1A
  • QuickBird
  • SPOT-6
  • WorldView-1 through -3

This tool runs on Windows 64-bit platforms and requires a separate license for the ENVI Photogrammetry Module (formerly the ENVI Orthorectification Module), which also includes access to Rigorous Orthorectification.

QUAC

The QUick Atmospheric Correction (QUAC)® algorithm was updated to the latest baseline source code from Spectral Sciences, Inc. The following reference summarizes the updated algorithm:

Bernstein, L.S., X. Jin, B. Grebor, and S. Adler-Golden. "Quick Atmospheric Correction Code: Algorithm Description and Recent Upgrades." Optical Engineering 51, No. 11 (2012): 111719-1 to 111719-11.

It contains the following enhancements to improve the accuracy of atmospheric correction:

  • Applies mud filtering to exclude highly structured materials.
  • Selects endmembers based on a small subset of available bands for most sensors. When a sensor spans both the visible and NIR-SWIR spectral regions, the algorithm excludes bands in the visible region.
  • Constrains the gain curve to be constant for wavelengths below 650 nm.
  • Suppresses the effects of dense vegetation.
  • Removes cloud endmembers for hyperspectral sensors with 940 to 1020 nm water absorption bands.

QUAC also works with images where pixels are masked out or set to NoData, NaN, or Infinity.

GMTED2010

A higher-resolution version of the GMTED2010 (7.5 arc seconds) is available for download from the Exelis VIS website. We recommend using this version for RPC Orthorectification and automatic tie point generation in Image Registration because it will significantly improve the accuracy of the results. See the "GMTED2010 Overview" topic in ENVI Help for details.

New Spectral Indices

The Normalized Difference Mud Index (NDMI) highlights muddy or shallow-water pixels. This index was originally designed as a filter to exclude those pixels and to improve the accuracy of QUick Atmospheric Correction (QUAC)®.

The Modified Normalized Difference Water Index (MNDWI) enhances open water features while suppressing noise from built-up land, vegetation, and soil. Xu (2006) reported that the MNDWI produced better results than the Normalized Difference Water Index originally developed by McFeeters (1996) in enhancing and extracting water from a background that is dominated by built-up land areas.

The Spectral Indices tool now lists only the spectral indices that are available to compute from an input raster, based on its wavelength metadata. It previously listed all spectral indices, then issued an error message if you selected any that could not be computed for the input raster.

User Interface

Numerous performance enhancements have been included in this release, improving the speed and efficiency of ENVI when working with multiple datasets and raster series animation.

ENVI imagery can now be saved to Geospatial PDF files. Select File > Chip View To > Geospatial PDF to capture all georeferenced data layers displayed in the current view, or use File > Export View To > Geospatial PDF to select and export entire georeferenced raster layers.

Use the Regrid Raster Series tool (under the Spatiotemporal Analysis folder in the Toolbox) to define a custom grid and to regrid a raster series to it. A custom grid definition is a combination of a coordinate system, spatial extent, pixel size, number of rows and columns, and/or tie-point pixel and map coordinates.

Right-click on the Classes folder of an ENVI classification image and select Edit Class Names and Colors to edit the default names and colors of individual classes.

The Clump Classes and Sieve Classes dialogs allow you to preview processing results.

The Edit ENVI Header dialog has been replaced by the Set Raster Metadata dialog. Use this to edit the values of ENVI header fields and to save the results to an ENVI header file. In the Toolbox, select Raster Management > Edit ENVI Header to access the Set Raster Metadata tool.

The Jagwire product, available from Exelis VIS, provides a server that streams imagery and video for display and analysis. Use the redesigned and simplified Remote Connection Manager to connect to Jagwire servers, to perform spatial and time queries on their contents, and to open raster data that represents properties of geographic locations.

The File Selection dialog now includes buttons for subsetting by raster, by vector, by region of interest (ROI), or by map coordinates. Click the Spatial Subset button in the File Selection dialog to access these options.

The File > Save As menu option now includes options for creating a masked raster file. A mask can be defined from another raster, a vector, or one or more ROIs. Click the Mask button in the File Selection dialog to access these options.

The ENVI LiDAR application has been merged into ENVI. To open the ENVI LiDAR window select LiDAR > Launch ENVI LiDAR from the Toolbox, or select Display > ENVI LiDAR from the ENVI menu bar.

Analyze data over time with a spatiotemporal Series Profile. From the main menu, select Display > Profiles > Series to launch the plot window.

ENVI profiles now provide adjustable smoothing to plotted data. Select Options > Curve Smoothing to display the slider control.

Programming

ENVIQUACTask and ENVI_QUAC_DOIT were updated to the latest algorithm from Spectral Sciences, Inc., documented in the following reference:

Bernstein, L.S., X. Jin, B. Grebor, and S. Adler-Golden. "Quick Atmospheric Correction Code: Algorithm Description and Recent Upgrades." Optical Engineering 51, No. 11 (2012): 111719-1 to 111719-11.

Tasks

The following table lists new ENVITasks. You can also publish these tasks to client applications using ENVI Services Engine.

Task Description
ENVIAdditiveLeeAdaptiveFilter
Apply a Lee adaptive filter to smooth noisy data that has an additive component.
ENVIAdditiveMultiplicativeLeeAdaptiveFilterTask Apply a Lee adaptive filter to smooth noisy data that has an additive and multiplicative component.
ENVIBinaryGTThresholdRasterTask Create a raster where values above a specified threshold are set to 1 and all other values are set to 0.
ENVIBinaryLTThresholdRasterTask Create a raster where values below a specified threshold are set to 1 and all other values are set to 0.
ENVIBitErrorAdaptiveFilterTask Apply a bit error adaptive filter to a raster.
ENVIBuildMosaicRasterTask Build a mosaic raster based on a set of input rasters.
ENVICalculateQUACGainOffsetTask Calculate the gain and offset for QUAC on multispectral or hyperspectral imagery.
ENVIDataValuesMaskRasterTask Export a data values mask raster to an ENVI-format file.
ENVIDirectionalFilterTask Apply a directional filter to a raster.
ENVIDirectionalKernelTask Define a directional kernel for use with convolution filtering.
ENVIEnhancedFrostAdaptiveFilterTask Apply an enhanced Frost filter to a raster, to reduce speckling while preserving edges.
ENVIEnhancedLeeAdaptiveFilterTask Apply an enhanced Lee filter to a raster, to reduce speckling while preserving texture information.
ENVIExportColorSlicesTask Export raster color slices to a density slice range (DSR) file.
ENVIFrostAdaptiveFilterTask Apply a Frost filter to a raster, to reduce speckling while preserving edges.
ENVIGammaAdaptiveFilterTask Apply a gamma filter to a raster, to reduce speckling while preserving edges.
ENVIGaussianHighPassFilterTask Apply a Gaussian high pass filter to a raster.
ENVIGaussianHighPassKernelTask Define a Gaussian high pass filter for use with convolution filtering.
ENVIGaussianLowPassFilterTask Apply a Gaussian low pass filter to a raster.
ENVIGaussianLowPassKernelTask Define a Gaussian low pass filter for use with convolution filtering.
ENVIGeneratePointCloudsByDenseImageMatchingTask Generate 3D point clouds from two or more images taken from different view points using a dense image matching method.
ENVIGeoJSONToROITask Convert GeoJSON features to a region of interest (ROI).
ENVIGeoPackageToShapefileTask Convert GeoPackage vector files to Shapefile format.
ENVIGetColorSlicesTask Get data ranges and colors  from a density slice range (DSR) file.
ENVIGetSpectrumFromLibraryTask Retrieve the details of a specified material from a spectral library.
ENVIHighClipRasterTask Create a new raster where values above a threshold are set to the threshold.
ENVIHighPassFilterTask Apply a high pass filter to a raster.
ENVIHighPassKernelTask Define a high pass kernel for use with convolution filtering.
ENVIKuanAdaptiveFilterTask Apply a Kuan adaptive filter to a raster.
ENVILaplacianFilterTask Apply a Laplacian filter to a raster.
ENVILaplacianKernelTask Define a Laplacian kernel for use with convolution filtering.
ENVILocalSigmaAdaptiveFilterTask Apply a Local Sigma adaptive filter to a raster.
ENVILowClipRasterTask Create a new raster where values below a threshold are set to the threshold.
ENVILowPassFilterTask Apply a low pass filter to a raster.
ENVILowPassKernelTask Define a low pass kernel for use with convolution filtering.
ENVIMaskRasterTask Export a mask raster to an ENVI-format file.
ENVIMedianFilterTask Apply a median filter to a raster.
ENVIMultiplicativeLeeAdaptiveFilterTask Apply a Lee adaptive filter to smooth noisy data that has an multiplicative component.
ENVIROIMaskRasterTask Export an ROI mask raster to an ENVI-format file.
ENVIQuerySpectralLibraryTask Query a spectral library, returning the names of all spectra in the library.
ENVIQueryTaskTask View property descriptions for a selected ENVITask.
ENVIQueryTaskCatalogTask View a list of available tasks in ENVI.
ENVIRasterConvolutionTask Apply a convolution filter to a raster.
ENVIRasterHistogramTask Compute the histogram of a raster.
ENVIRasterMetadataItemTask Retrieve the value of a given raster metadata key.
ENVIRegridRasterSeriesTask Reproject a series of rasters to a common spatial grid, using a custom grid definition.
ENVIReprojectRasterTask Reproject a raster from one coordinate system to another.
ENVIResampleSpectrumTask Resample a given spectrum to a different set of wavelengths, typically from a hyperspectral image.
ENVIRobertsFilterTask Apply a Roberts filter to a raster.
ENVISetRasterMetadataTask Set metadata values for a raster that does not have an associated ENVI header file (.hdr). This task creates a new header file and saves it to a specified location on disk.
ENVISobelFilterTask Apply a Sobel filter to a raster.
ENVISpectralAdaptiveCoherenceEstimator
UsingSubspaceBackgroundStatisticsTask
Perform Adaptive Coherence Estimator (ACE) target detection analysis, using the mean and covariance from subspace background statistics.
ENVISpectralSubspaceBackgroundStatisticsTask Compute background statistics by excluding anomalous pixels.
ENVIVectorMaskRasterTask Export a vector mask raster to an ENVI-format file.
ENVIVectorRecordsToSeparateROITask Create individual ROIs from each geometry record in a vector.

Objects and Methods

Object or Method Description
ENVIBinaryGTThresholdRaster Construct an ENVIRaster from a source raster where pixel values above a specified threshold are set to 1 and all others are set to 0.
ENVIBinaryLTThresholdRaster Construct an ENVIRaster from a source raster where pixel values below a specified threshold are set to 1 and all others are set to 0.
ENVIDataValuesMaskRaster Construct an ENVIRaster from a source raster and a specified data range, where each pixel within the data range will not be masked.
ENVIGainOffsetWithThresholdRaster Construct an ENVIRaster from a source raster with gains and offsets applied. Optionally constrain the resulting pixel values  to a specified range.
ENVIHighClipRaster Construct an ENVIRaster from a source raster where values above a threshold are set to the threshold.
ENVIJagwireServer Reference an ENVIJagwireServer object.  You can:
  • Query a hash table of raster datasets available on the Jagwire server
  • Query a hash table of dataset metadata
  • Close the Jagwire server connection in ENVI
ENVILowClipRaster Construct an ENVIRaster from a source raster where values below a threshold are set to the threshold.
ENVIQUACRaster Construct an ENVIRaster from a source raster that has QUick Atmospheric Correction (QUAC) applied.
ENVIReprojectRaster Construct an ENVIRaster from a source raster that has been reprojected to a different coordinate system.
ENVIRoi::GetExtent Return the pixel coordinates boundary of the ROI for a given ENVIRaster.
ENVISpectralLibrary Create an ENVI spectral library object.
ENVIView::Chip Create a new ENVIRaster from the contents of a view.
ENVIView::ChipToFile Chip the contents of a view directly to a file.

ENVI LiDAR Objects, Methods, and Tasks

ObjectMethod/Task Description
ENVI::OpenPointCloud
This method opens one or more point cloud files. It also opens a single ENVI LiDAR project file.
ENVI::QueryPointCloud
The QueryPointCloud function method opens a single point cloud file.
ENVICreatePointCloudSubProjectTask This task divides an existing ENVI LiDAR project into a number of subprojects for simultaneous processing by a number of ENVI Services Engine (ESE) workers.
ENVIPointCloud This method is a reference to a point cloud object, to which you can:

  • Get points within a circle region
  • Get points within a polygon region
  • Get spatially sorted points within a given range
  • Get points within a rectangle region
  • Get points within a specified tile
  • Save the ENVIPointCloud object
  • Write points to a new LAS file
  • Close the ENVIPointCloud object
ENVIPointCloudFeatureExtractionTask This task performs feature extraction on point cloud data.  Building, tree, and power line feature extraction can be performed with the purchase of the ENVI Feature Extraction license. It also includes a validate task.
ENVIPointCloudFilter This is a reference to an ENVIPointCloud point filter object. It is used to filter the point data that will be returned from the point query methods of the ENVIPointCloud object.
ENVIPointCloudMetadata This is a reference to a point cloud metadata object.
ENVIPointCloudProductsInfo This object stores the fully-qualified filenames for all products generated by ENVIPointCloudFeatureExtractionTask.
ENVIPointCloudQuery This method is a reference to a point cloud object that has not been built into an optimized file format (i.e., an ENVI LiDAR .ini file). You can:

  • Get spatially sorted points within a given range
  • Close the ENVIPointCloudQueryobject
ENVIPointCloudSpatialRef This method creates an ENVIPointCloudSpatialRef object, to which you can:

  • Convert lat/lon coordinates to map coordinates
  • Convert map coordinates to lat/lon coordinates
  • Convert coordinates map-to-map
ENVIPointCloudViewer This method starts the ENVI LiDAR application and returns an object reference to the instance of the application. You can:

  • Open an ENVIPointCloud object in the viewer
  • Open a shapefile in the viewer
  • Get an ENVIPointCloud object that is already open in the viewer
  • Get the view extents
  • Set the location of the progress bar in the viewer
  • Set the view extents
  • Close the viewer
ENVISpatialSubsetPointCloud This method creates a new ENVISpatialSubsetPointCloud object which is a spatial subset of an existing ENVIPointCloud object.

Messaging

Use the following objects and methods to add progress notification, or messaging, to ENVI API scripts.

Object or Method Description
ENVI::GetBroadcastChannel
This method returns an object reference to the system's broadcast channel.
ENVIAbortable Use this class to communicate if an abort is requested.
ENVIAbortableTaskFromProcedure Use this base class when writing custom tasks that will have a progress dialog with an option to abort the process. This base class has its own set of PreExecute, DoExecute, and PostExecute methods.
ENVIBroadcastChannel This is a reference to a broadcast channel object, to which you can:

  • Send messages using the Broadcast method
  • Subscribe using the Subscribe method
  • Unsubscribe using the Unsubscribe method
ENVIMessage This is an abstract class used as a superclass for other message classes.
ENVIMessageHandler This is an abstract class used as a super class for other message classes. ENVIBroadcastChannel calls the ENVIMessageHandler::OnMessage method to forward messages to all of its subscribers.
ENVIStartMessage This function constructs an ENVIStartMessage object to send to the ENVIBroadcastChannel. If the ENVI user interface is running, then a progress dialog will appear.
ENVIProgressMessage This function constructs an ENVIProgressMessage object to send to the ENVIBroadcastChannel. If the ENVI user interface is running with a progress dialog, the dialog will update.
ENVIFinishMessage This function constructs an ENVIFinishMessage object to send to the ENVIBroadcastChannel. If the ENVI user interface is running with a progress dialog, the dialog will close.

See the "Custom Tasks with Abortable Progress Reports" topic in ENVI Help for instructions on creating custom tasks with the option to display a progress report and an option to abort (cancel) the task.

Known Issues

ENVI-70066 Opening two GF-1 WFV images results in image artifacts
Opening two Gaofen-1 images in the same view results in data gaps. Workaround: Display multiple Gaofen-1 images in separate views.
ENVI-70110 Georeferencing from GLT produces holes in a south polar stereographic projection
When using Latitude/Longitude bands to create a geographic lookup table (GLT), images geogreferenced using the GLT in a southern hemisphere polar stereographic projection contain holes near their center.
ENVI-70139 Vector layer is hidden temporarily on "Accept" while animating a raster series
If you draw a polygon vector layer and accept it while a raster series is animating, the polygon layer disappears. Workaround: Pause the animation between Accept operations, or step through the series one frame at a time while editing the vector layer.
LIDAR-68971 GDAL cannot create JPEG output because neither canCreate nor canCopy is supported
A jpeg orthophoto cannot be generated when the export projection is set to Lat/Lon. Workaround: 1) Use an export projection other than Lat/Lon, 2) Use a working image type (TIF, ENVI).
LIDAR-69052 When using arbitrary coordinates, ENVI LiDAR cannot export products using units of feet
When generating products, please ensure that Units are set to Meters under the Export Coordinate System section. To avoid this issue, please select the correct projection for your data at project creation time.

JPEG2000 files are not supported in Rigorous Orthorectification (ENVI Photogrammetry Module)
This issue only affects SPOT-6, SPOT-7, and Pleiades.

Fixed Issues

CLASSIC-68552 In FLAASH, the "Automatically Save Template File" and "Output Diagnostic Files" parameters in the Advanced Settings page were not written to the template file.
CLASSIC-68551 ENVI Classic did not recognize projections in TIFF files that the ENVI API could.
CLASSIC-68537 ENVI Classic issued a READU error with ENVI_EXTRACT_DEM_DOIT.
CLASSIC-68483 ASCII XYZ output had six columns rather than three.
CLASSIC-46337 ENVI Classic did not correctly orient georeferenced ASAR imagery.
Documentation included an invalid formula for calculating the kappa coefficient.
ENVI-70530 ENVI issued an OSELECTED error when closing a file, if bands were selected in the Data Manager.
ENVI-70524 ENVI issued an error and crashed when running ENVI Classic tools if the Display Errors on Screen preference was set to No.
ENVI-70516 ENVI issued an error when editing 2D polygon shapefiles.
ENVI-70514 The Series/Animation Manager menu item was disabled even when series layers were selected in the Layer Manager.
ENVI-70513 ENVI crashed when the Band Animation dialog was closed during playback.
ENVI-70511 The ALSAT-2A filter function was invalid.
ENVI-70510 ENVI did not connect to WMS version 1.1.0 servers.
ENVI-70505 Stacked plots did not match the order of the plot legend.
ENVI-70502 Auto Input via Z-profile failed in Spectral Analyst.
ENVI-70500 Users could not edit Y-axis ranges when plots were stacked in the Spectral Profile.
ENVI-70495 ENVI issued an error and crashed when applying an ROI threshold mask to rasters.
ENVI-70490 Building a mask took a long time when using a thresholded ROI.
ENVI-70489 Band names of SPOT RGB images were incorrect in Layer Manager.
ENVI-70486 Users could edit headers for data that was in a read-only directory.
ENVI-70483 ENVI did not recognize RPC information from WorldView-2 data.
ENVI-70482 Reprojecting ADS40 images with RPC information resulted in non-square pixels.
ENVI-70478 Two rasters with the same prefix and additional dots in the filenames would both close if users closed one raster.
ENVI-70474 ALOS-2 Level 1.5 data in CEOS format were not correctly georeferenced.
ENVI-70473 ENVI::OpenRaster did not recognize ENVI .enp (pyramid) and .hdr (header) files.
ENVI-70467 Bands were still listed in the Data Manager after closing a file.
ENVI-70462 ENVI crashed when opening some WorldView-3 tiled files.
ENVI-70460 Users could not manually change the threshold in the Image Change workflow.
ENVI-70459 The Open Recent file list did not include files that were dragged and dropped into the display.
ENVI-70458 The Open Recent file list did include all files opened through multiple file selection.
ENVI-70456 ENVI did not open any more files after loading more than 20 NITF files with C8 or M8 image compression.
ENVI-70452 Spectral profiles created from ENVI Classic tools did not maintain X and Y plot ranges.
ENVI-70446 Axis titles were not preserved in plot windows.
ENVI-70445 ENVI did not allow saving an image or chip to JPEG format with a quality level.
ENVI-70439 Time series animation stopped while image frames were loading.
ENVI-70437 ALOS PALSAR documentation was incorrect about real and imaginary components.
ENVI-70434 GLT reprojection was slow for large images.
ENVI-70433 ENVI issued an EFFECTIVEBANDWIDTHS error when opening some GeoEye-1 datasets.
ENVI-70431 ENVI issued an error when exporting an ENVIQUACRaster to a Geospatial PDF file in the ENVI API.
ENVI-70428 ENVIMetaspectralRaster did not inherit gains and offsets from input rasters.
ENVI-70427 Starting ENVI runtime or ENVI+IDL caused an error after installation, requiring a reinstallation.
ENVI-70422 The code example for ENVIRasterMetadata listed the wrong number of bands for the selected raster.
ENVI-70417 The Polarization Signature Viewer was hidden behind the main ENVI application window.
ENVI-70407 ENVI did not read some SkySat metadata files.
ENVI-70405 The Spectral Subset section of the input file selection dialog did not apply the Bad Bands List by default.
ENVI-70404 ENVI issued a memory allocation error when calculating statistics for all ROIs.
ENVI-70401 ALOS-2 Amplitude, I, and Q imagery displayed as an RGB composite instead of black and white.
ENVI-70400 The Spectral Hourglass Wizard did not honor spectral subsets in the classification process.
ENVI-70399 ENVI issued an error when loading vector images on top of GLT-projected images.
ENVI-70394 The Metadata Viewer was still open after its respective image was closed.
ENVI-70393 Users could open multiple Metadata Viewer dialogs per image.
ENVI-70392 Red and green band names and wavelengths were incorrect in the Data Manager for WorldView-2 four-band datasets.
ENVI-70389 SPOT-7 PMS three-band products were missing some metadata.
ENVI-70388 Documentation was incorrect for Parallelepiped Classification.
ENVI-70383 Some ENVI dialogs still had a Queue button, which is no longer functional.
ENVI-70375 ENVI issued an error when starting the Build Mask tool.
ENVI-70368 Documentation was incorrect for the VALUE keyword in ENVI_REPORT_ERROR.
ENVI-70360 IKONOS wavelength values did not match published values.
ENVI-70354 The Data Manager listed incorrect wavelengths for NPP VIIRS SDR datasets.
ENVI-70348 ROI layers with hundreds of ROIs did not display correctly.
ENVI-70346 DEM Extraction failed with WorldView-3 panchromatic datasets.
ENVI-70344 The Rule Classifier dialog was hidden behind the main ENVI application.
ENVI-70343 ENVI did not clearly define what wavelength units it recognized.
ENVI-70342 GeoTIFF imagery did not open with standard map information.
ENVI-70341 ENVI did not tile TIFF images correctly with some GeoEye-1 tiled datasets.
ENVI-70338 Output header files from running ENVIQUACTask did not honor the DATA_IGNORE_VALUE.
ENVI-70335 Users could not restore an ENVIROIMaskRaster in the ENVI API.
ENVI-70333 The FLAASH output directory was not created unless users pressed the Enter key.
ENVI-70332 The FLAASH Spectral Polishing Width returned to a previous value unless users pressed the Enter key.
ENVI-70327 Shapefiles with an arbitrary projection created with ENVI LiDAR did not display correctly over an arbitrary-projected DEM.
ENVI-70326 ENVI could not create an RGB composite from two bands.
ENVI-70304 ENVISpectralIndexRaster yielded different results for the Red Green Ratio Index than did ENVI_VEG_INDEX_DOIT.
ENVI-70284 WorldView-3 was not included in the Spectral Resampling pre-defined filter function list.
ENVI-70273 The Series/Animation Manager played back twice as slow when a pyramid file was present.
ENVI-70230 The Overlay Classes tool did not work correctly.
ENVI-70206 The default linear stretch value was not honored in header files.
ENVI-70201 ENVI returned unexpected results when using Band Math with negative pixel values.
ENVI-69939 ENVIImageIntersectionTask issued an error message with single-band BIP input rasters.
ENVI-69893 ENVI crashed while building pyramids for tiled GeoEye data in DigitalGlobe format.
ENVI-68463 The Edit ENVI Header tool used an old coordinate system selection dialog.
ENVI-68135 The Decision Tree Classification help topic was updated to remove unsupported special variables.
ENVI-68029 Some TIFF files displayed with a custom stretch that could not be changed.
LIDAR-69036 Certain building perimeter shapefiles would not display in ENVI.
LIDAR-69012 Datasets were not recognized as open if CreateLidarFromSubrect method was used.
LIDAR-69003 LiDAR was incorrectly displaying AgerPoint files with extra bytes stored after the last point record.
LIDAR-68994 Vector files were not displayed properly when products were generated at 50 cm resolution.
LIDAR-68992 RGB values were not correctly recognized in projects created from a .txt file.
LIDAR-68989 Projects with a file path longer than 256 characters were incorrectly indentified as being read-only.
LIDAR-68862 The LiDAR API was not saving the spatial reference for LAS file output.

Backward-Compatibility Notes

Partial strings are no longer allowed for the TaskName argument of ENVITask because of the growing number of tasks with common strings. For example, you could enter the following at the IDL command line in ENVI 5.2 SP1 and earlier:

IDL> e = ENVI()
IDL> task = ENVITask('iso')

This would assign the task variable to ENVIISODATAClassificationTask. Now it issues an error message but also provides the tasks that contain the partial string.

Please login or register to post comments.